Multiple email invites sent to some panellists for the surveys.
Incident Report for Cint
Resolved
This incident has been resolved.
Posted Dec 20, 2019 - 07:57 UTC
Monitoring
Good news! The issue has been addressed and our team is closely monitoring the platform's performance. Everything should be back to normal. We apologize for any inconvenience this may have caused and thank you once again for your understanding.
Posted Nov 27, 2019 - 15:38 UTC
Investigating
Hi, we are currently experiencing an issue where panellists sometimes get several invites in a row despite the the panel/panellist settings specifying a limit of number of invitations. We are aware of the issue and we are working on a solution. We will provide you with regular updates on our progress, and thank you for your patience in the meanwhile.
Posted Nov 26, 2019 - 09:21 UTC
This incident affected: Panel/Respondent Services (Email Services).