test
Incident Report for Cint
Resolved
This incident has been resolved.
Posted Oct 27, 2020 - 16:21 CET
Update
We are continuing to investigate this issue.
Posted Oct 27, 2020 - 16:20 CET
Investigating
We are currently investigating this issue.
Posted Oct 27, 2020 - 16:20 CET
This incident affected: Insight Exchange - Project Management Admin.