Cint Platform Issue: Unable to access Cint Exchange

Incident Report for Cint

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 14:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 14:15 UTC

Investigating

We are currently investigating reports of the Cint Exchange User Interface (UI) failing to load for some users, resulting in timeout errors. Our team is actively developing and implementing additional fixes to restore normal functionality. We will provide further updates as they become available.
Posted Jul 14, 2025 - 13:31 UTC
This incident affected: Demand Exchange Services (Cint Exchange).