Cint Platform Issue: Cint Exchange - Unable to load Projects

Incident Report for Cint

Update

We have identified the cause of the issue and are working to provide a resolution. We will continue to provide updates when new information is available.
Posted Jul 02, 2026 - 14:02 UTC

Identified

We are investigating reports where project details are not being displayed for some users. We have identified the root cause as a stale user session.

Our team is actively working on a permanent fix and will provide an update soon. In the meantime, affected users can clear their browser's cache and cookies, or sign in using a different browser as a temporary workaround.
Posted Jul 02, 2026 - 09:52 UTC
This incident affects: Cint Exchange Services (Cint Exchange UI).